Gros ralentissement sur SOLIDWORKS

Bonjour tout le monde,

Je rencontre beaucoup de ralentissement lors de la conception de mes assemblages depuis quelque temps.

Il y a eu plusieurs ajustement :

  • changement de matériel (passage d’une tour fixe à une station de travail portable)
  • mise en place d’une nouvelle configuration solidworks (modèle de document, propriété personnalisé, quelque macro, …)
  • Je travail à 100% sur le local du PC (sauf si j’ai loupé quelque chose dans la configuration solidworks)
  • Pas de PDM

les principaux problèmes que je rencontre dans les assemblages sont les suivants :

  • lors ce que j’ajoute des contraintes en sélectionnant deux face, la fenêtre avec les propositions de contrainte mets plus de 5s à s’afficher
  • quand je veux déplacer un corps, celui si ne se déplace pas à la 1er sélection mais à la 2ème ou 3ème
  • dans un assemblage un peut plus complexe comprenant quelques répétitions, symétrie de pièce (non symétrisée), je rencontre de très gros ralentissement pour la reconstruction de l’ensemble

Le matériel :
Processeur : Intel(R) Xeon(R) W-11855M CPU @ 3.20GHz 3.19 GHz
Version du BIOS : DELL inc. 1.15.2 du 08/09/2022
Mémoire RAM : 32,0 Go (31,2 Go utilisable)
Type de système : Système d’exploitation 64 bits, processeur x64
Windows 10 Professionnel 22H2

Avez vous une idée de la provenance de ce genre de problème ? est il possible que cela vienne de la configuration mise en place ?

Merci pour vos retour
Vincent

Pour tester si cela vient de ta configuration, réinitialise le profil.
Si c’est une version récent ede SW il suffit de lancer SWRX:
image
Puis de cliquer sur le lien en bleu pour ignorer le profil utilisateur et lancer SW avec le profil type (uniquement sur la prochaine session, ensuite le profil utilisateur réapparait)


Si c’est rapide lors du test c’est que ton profil est à revoir.
Si c’est la même chose lance un test de diagnostique avec le même logiciel (2ème onglet), voir un test de performance (dernier onglet)

5 Likes

Bonjour,
En complément de la réponse de @sbadenis , il faudrait aussi préciser s’il y a une carte graphique additionnelle ou non (type de carte et driver) ainsi que la version de SW.
Ce qui peut aussi influencer la performance est le nombre de composant dans l’assemblage (ou leur complexité), il faudrait donc un peu détailler la problématique.

3 Likes

Merci pour vos retours.

je suis sur SW2019

  • Le problème est identique à l’ouverture de plusieurs de mes assemblages avec la profil d’origine => donc le problème ne vient pas de mon profil
  • le diagnostique ne relève aucun problème

ci joint quelque captures

et description matériel
DxDiag.txt (182,4 Ko)

1 Like

Je n’ai pas souvenir que la 2019 était lente sur les ASM. En revanche un driver R525 pour la 2019 est beaucoup trop récent.
Pour la 2020 avec la T1200 on est au max sur R470, rien de certifié pour cette carte graphique pour la 2019.
Ca peut venir de là, à vérifier en mettant un driver plus ancien Hardware Certification (solidworks.com)

3 Likes

Merci pour ces informations, je vais voir ce que je peux faire avec notre service information.

Est il possible que cela provienne également des propriétés de pièces ou assemblage ?
Exemple ci dessous


A ma connaissance non, pas de lien avec les propriétés sauf s’il y a des recalculs ou des multitudes de configurations.

2 Likes

Les propriété ne font pas ralentir une pièce ou assemblage.
Je confirme l’analyse de @Cyril.f pour le driver et je tenterais d’installer un vieux driver également.
En espérant que ce soir plus compatible car la Quadro T1200 semble être sortie en 2021 soit après les dernière SP de SW2019.

1 Like

Pensez aussi à vérifier les paramètres du driver de la carte graphique.
Est ce que SW a bien été choisi comme type de logiciel ?

1 Like

Bonjour à tous,

Je vous partage un document qui a été réalisé par nos formateurs pour optimiser les performances dans SOLIDWORKS. Il date de 2022 mais je pense que cela peut vous donner des axes d’améliorations !

Performances SOLIDWORKS.pdf (2,7 Mo)

1 Like